Module helma/src/helma/util/

back to main page

Summary Period: 2000-12-29 to 2006-01-13

Modules

[root]/helma/src/helma/util
     mime (0 files, 0 lines)

Lines of Code


Total Lines Of Code: 7703 (2006-01-13 18:49)

Authors

Author Changes Lines of Code Lines per Change
Totals 203 (100.0%) 12635 (100.0%) 62.2
hannes 196 (96.6%) 12444 (98.5%) 63.4
stefanp 5 (2.5%) 185 (1.5%) 37.0
kmfdm 1 (0.5%) 4 (0.0%) 4.0
tobi 1 (0.5%) 2 (0.0%) 2.0

Most Recent Commits

hannes 2006-01-13 14:20

* Add setter and getter for logLevel.

19 lines of code changed in:

hannes 2005-09-01 23:57

* Put copy-on-write WrappedMap into separate class in order to be able to synchronize
all of its methods, which is necessary to catch the switch between original and copied map,
and which isn't necessary for ordinary and read-only WrappedMaps.

146 lines of code changed in:

hannes 2005-08-31 14:18

* add getResources().

10 lines of code changed in:

hannes 2005-08-29 18:13

* Simplify checks for ignoreCase.

7 lines of code changed in:

hannes 2005-08-09 15:37

Normalize upload file names by cutting off any path info before the actual file name.

19 lines of code changed in:

hannes 2005-07-29 13:45

* Switch to Jakarta Commons FileUpload for handling file uploads.
* Introduce uploadSoftfail setting in apps.properties that allows
file upload errors to be cought by checking req.data.helma_upload_error

0 lines of code changed in:

hannes 2005-07-20 15:50

Remove debugging output.

1 lines of code changed in:

hannes 2005-07-20 15:49

* Fix bug 435, cron jobs are run even if the function name is not defined
* Fix a bug that caused the scheduler thread to awaken twice in immedate
succession because of imprecise timing in Thread.sleep()

19 lines of code changed in:

hannes 2005-07-12 11:39

Add new constructor that takes ignoreCase flag, because it can't be set later for app/resource name properties.

20 lines of code changed in:

hannes 2005-06-28 12:03

make class not final

3 lines of code changed in:

hannes 2005-06-22 10:37

Go back to old log file rotation code layout a bit, but still only use one thread to gzip all rotated files:
- GZipper class is with FileLogger again and takes either a list of files or a single file
- Log file rotation is done synchronously in the Logging.Runner thread, only gzipping is done in
a separate thread

72 lines of code changed in:

hannes 2005-06-16 21:57

Rewrote log file rotation to use just one thread for zipping all log files.

105 lines of code changed in:

hannes 2005-06-09 18:34

Simplified getInstance(String) a little bit.

6 lines of code changed in:

hannes 2005-06-09 18:32

Set thread priority for GZipper threads to MIN_PRIORITY.

3 lines of code changed in:

hannes 2005-06-09 13:46

- Remove old debug thread dump in getInstance(String)
- Remove double checking to avoid entering synchronized code in getInstance(String)
- Rename newLog(String) to getFileLogger(String) and clean it up a little bit

10 lines of code changed in:

hannes 2005-06-09 13:23

Make Runner.run() synchronized again, needed by wait()

3 lines of code changed in:

hannes 2005-06-09 13:15

Remove comment about bogus thread safety, not true anymore after last commit.

2 lines of code changed in:

hannes 2005-06-09 13:02

- No need to make runner volatile since it is only access in synchronized code
- Do not null out Logging.runner at the end of Runner.run()
- Remove unused Runner.wakeup() method and make runner.run() not synchronized

4 lines of code changed in:

hannes 2005-06-09 12:42

- Make sure we use an absolute path for logdir
- Make all methods that work on the logfile/writer synchronized
- Increase Buffer size in GZipper thread to 8192 bytes

13 lines of code changed in:

hannes 2005-06-06 21:28

Make runner variable volatile.

3 lines of code changed in:

(135 more)

Generated by StatCVS 0.2.2