Pages: « Previous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 Next »
Summary Period: 2003-10-14 to 2003-09-09 (Commits 2189-2238 of 3188)
* Increase default uploadLimit for file upload to 4 MB
3 lines of code changed in:
* Moved getSubHeader() method from FileUpload to MimePart and made it public static
* Check charset in MimePart.getText()
* Increase default uploadLimit in FileUpload to 4 MB
49 lines of code changed in:
wrapper function Xml.getFromString(str) called Xml.get() instead of Xml.getFromString(str, null)
3 lines of code changed in:
Recognize application/text in getText()
4 lines of code changed in:
Implement support for Xml.get() and Xml.getFromString().
Added JavaDoc comments.
127 lines of code changed in:
* Implement mechanism to register parent nodes with changed child nodes with the transactor.
When finishing the transaction, the transactor will call setLastSubnodeChange() on
the parent nodes. This is necessary because the lastSubnodeChange flag should only be
set after child node changes have been committed to the database.
(Fixes bug 285 http://helma.org/bugs/show_bug.cgi?id=285 )
* Changed the way select statements are built: Use tablename.* rather than * to prevent
columns from additionalTables are fetched unnecessarily.
* Code cleanup everywhere, mostly in Transactor.java, Relation.java and NodeManager.java
100 lines of code changed in:
* Implement mechanism to register parent nodes with changed child nodes with the transactor.
When finishing the transaction, the transactor will call setLastSubnodeChange() on
the parent nodes. This is necessary because the lastSubnodeChange flag should only be
set after child node changes have been committed to the database.
(Fixes bug 285 http://helma.org/bugs/show_bug.cgi?id=285 )
* Changed the way select statements are built: Use tablename.* rather than * to prevent
columns from additionalTables are fetched unnecessarily.
* Code cleanup everywhere, mostly in Transactor.java, Relation.java and NodeManager.java
194 lines of code changed in:
* Implement mechanism to register parent nodes with changed child nodes with the transactor.
When finishing the transaction, the transactor will call setLastSubnodeChange() on
the parent nodes. This is necessary because the lastSubnodeChange flag should only be set
after child node changes have been committed to the database.
(Fixes bug 285 http://helma.org/bugs/show_bug.cgi?id=285 )
* Changed the way select statements are built: Use tablename.* rather than * to prevent
columns from additionalTables are fetched unnecessarily.
* Code cleanup everywhere, mostly in Transactor.java, Relation.java and NodeManager.java
24 lines of code changed in:
Consider comma separated lists of IP addresses in addIPAddress()
12 lines of code changed in:
Wrap HopObject array items before building JS Array in HopObject.list().
3 lines of code changed in:
Fix cache setter from setcache() to setCache()
3 lines of code changed in:
compile _as_string variants for legacy templates (.hsp)
7 lines of code changed in:
upgraded to version 0.4
3 lines of code changed in:
upgraded to version 0.4
4 lines of code changed in:
cleanup
2 lines of code changed in:
added serialVersionUID to remain compatible with older versions
2 lines of code changed in:
fully implemented getRemote() for distributed function calls
77 lines of code changed in:
fully implemented wrap(), unwrap(), setProperty(), waitFor(), getLastError()
moved object conversion rhino-2-java to an extra function
165 lines of code changed in:
root object is always fetched from objects hashtable, no need for an extra field
2 lines of code changed in:
changed list() and getIds() to work with new wrapping mechanism
34 lines of code changed in:
RhinoGroupExtension.getExtension/putExtension associate
rhinoextension object with toplevel scope (and not with thread)
some cleanup
13 lines of code changed in:
fixed bug with creating root objects:
if getRoot() was called before STATE_CONNECTED was reached,
initial creation of a root object went into nowhere. root object then was
created again when it was need for the first time. so actually we've had
two root objects, the first of which was discarded immediately.
7 lines of code changed in:
- use RhinoGroupExtension.getWrapper() for creating RhinoGroupObjects
- added some debugging info, changed toString()
16 lines of code changed in:
changed toString()
16 lines of code changed in:
- use RhinoGroupExtension.getWrapper() for creating RhinoGroupObjects
- get() and has() now check for function objects at the super class or prototype
- added some debugging info
22 lines of code changed in:
added a wrapper cache for each rhinogroupextension object (= each evaluator)
24 lines of code changed in:
- adapted the way RhinoGroupExtension's are retrieved
- added list(), size() and count()
- fixed get(), has() and put() so that function objects are always
returned correctly (finally!)
- added debug(), removed system.out-statements
63 lines of code changed in:
- class now extends ScriptingExtension, therefore rewrote initialization
- static cache of all extensions now associated via thread
and not via scope anymore
- duplicated constructor so that both RhinoGroupObject and GroupObject work
46 lines of code changed in:
Implemented experimental formatParagraphs() method that uses p tags to format paragraphs
31 lines of code changed in:
Reworked formatting code
Implemented paragraph formatting
Fixed bug with newlines in pre tag
135 lines of code changed in:
Fix bug in previous commit: Make children persistable before setting
collection/mountpoint to virtual, otherwise children will be lost.
3 lines of code changed in:
Rewrote makePersistentCapable() as makePersistable() to properly handle
collections/mountpoints that do not need to be persisted themselves but
need their child nodes to be processed. This fixed bug 274 "Accessing collections of transient
nodes turns them permanently transient" http://helma.org/bugs/show_bug.cgi?id=274
63 lines of code changed in:
Fix bug in needsPersistence() that didn't persist object references.
6 lines of code changed in:
Only check for executable bin/java if JAVA_HOME is set, and if it isn't found,
don't exit but just issue a warning and let the script go on.
15 lines of code changed in:
Fix for http://helma.org/bugs/show_bug.cgi?id=273
Be more precise about encoding newlines: Do not add any new linebreaks,
plus use the system specific line separator.
32 lines of code changed in:
added testscripts that show version of helmagroups,
test config and create a group without running helma.
-sender and -receiver options use javagroups-testclasses to
check multicast traffic
89 lines of code changed in:
kicked the last references to fesi in the main package
check if server is set when logging, so that we can use it without runing helma
added static void main() for some debug actions
31 lines of code changed in:
upgraded to version 0.3.2
1 lines of code changed in:
upgraded to version 0.3.2
removed javadocs from distribution
3 lines of code changed in:
changed compilation:
first compile main package and helmagroups.rhino.* package against a helma1.3-installation
then compile helmagroups.fesi.* package against a helma1.2 installation
5 lines of code changed in:
changed compilation:
first compile main package and helmagroups.rhino.* package against a helma1.3-installation
then compile helmagroups.fesi.* package against a helma1.2 installation
31 lines of code changed in:
made helmagroups.* packge work with any scripting extension
67 lines of code changed in:
Constraints-linkmode patch from Daniel Ruthardt
<http://grazia.helma.at/pipermail/helma-dev/2003-August/000272.html>
Changes to patch:
* Changed type.properties option name from "linkmode" to "logic"
* Added support for XOR
* Some internal code reorganization
44 lines of code changed in:
Remove support for [named] but still consider it when parsing.
6 lines of code changed in:
Do not try to resort to child object when getting a property (experimental)
6 lines of code changed in:
Call hasFunction() on the prototype rather than on HopObjects themselves to avoid fetching
references or child objects from database.
9 lines of code changed in:
* Always throw exception when there's an error in global code
* Reimplement hasFunction() on prototypes for HopObjects.
* rename putPrototype() to registerPrototype()
45 lines of code changed in:
updated to antville 1.1 database schema
0 lines of code changed in:
Added HopObject.getById() as proposed by Juerg Lehni
http://helma.org/bugs/show_bug.cgi?id=269
Added JavaDoc comments
34 lines of code changed in:
Print out exception's toString() rather then just its class.
3 lines of code changed in:
Pages: « Previous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 Next »
Generated by StatCVS 0.2.2