Pages: « Previous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 Next »
Summary Period: 2005-08-10 to 2005-06-06 (Commits 2989-3038 of 3188)
Convert rootPrototype and userPrototype fields to local variables.
4 lines of code changed in:
* Extract session cleanup and cron job invoker code from run()
into separate cleanupSessions() and executeCronJobs() methods
* Add some missing JavaDoc tags
159 lines of code changed in:
Do not insist on helma.jar to be in classpath. This is useful for running Helma
in alternative environments such as GCJ.
6 lines of code changed in:
Normalize upload file names by cutting off any path info before the actual file name.
19 lines of code changed in:
added try-catch-blocks around CronJob parsing and CronJob handling
66 lines of code changed in:
Add uploadSoftfail servlet init parameter
8 lines of code changed in:
Improve cron thread log output
9 lines of code changed in:
Simplify getCronJobs() implementation
3 lines of code changed in:
Minor plastic surgery: move item.delete() up a few lines.
3 lines of code changed in:
Delete upload file item after usage.
3 lines of code changed in:
* Use Hashtable instead of WeakHashMap for activeCronJobs - we're using function names as keys, so
it's actually bogus to use WeakHashMap, plus WeakHashMap is not synchronized.
* Add event log statements each time cron jobs are executed: List of cron jobs we're going to execute,
and the map of cron jobs still active from last time.
* Add log statement if CronRunner catches an exception, just so it behaves like the same-thread cron
execution code.
12 lines of code changed in:
Add app.getCronJobs() function that allows to retrieve the currently registered custom cron jobs.
This returns a JavaScript object with the function name as property names and the helma.util.CronJob
instance as property values.
24 lines of code changed in:
* Switch to Jakarta Commons FileUpload for handling file uploads.
* Introduce uploadSoftfail setting in apps.properties that allows
file upload errors to be cought by checking req.data.helma_upload_error
80 lines of code changed in:
Adding commons-fileupload.jar to classpath
3 lines of code changed in:
Adding Jakarta Commons FileUpload 1.0
0 lines of code changed in:
Renamed some variables in the cron job section of the run() method.
Rewrote cron job cleanup code at the end of run().
23 lines of code changed in:
Remove debugging output.
1 lines of code changed in:
* Fix bug 435, cron jobs are run even if the function name is not defined
* Fix a bug that caused the scheduler thread to awaken twice in immedate
succession because of imprecise timing in Thread.sleep()
19 lines of code changed in:
Should fix bug 434 <http://helma.org/bugs/show_bug.cgi?id=434>
* Synchronize all methods that call/rely on update().
* Make sure repositories and resources are not null after update() has been called.
18 lines of code changed in:
Invoke setReadonly(boolean) on the db connection depending on the type of statement we're about to send.
34 lines of code changed in:
Do not ignore case (i.e. switch property names to lower case) for db properties.
3 lines of code changed in:
Add new constructor that takes ignoreCase flag, because it can't be set later for app/resource name properties.
20 lines of code changed in:
Use Context.get/putThreadLocal() to register per-thread scopes for DynamicGlobalObject.
This is to fix some very obscure behaviour that was likely caused by the WeakHashMap code.
21 lines of code changed in:
Look up variables in per-thread scope first, then in shared global scope.
8 lines of code changed in:
Synchronize set/getSubnodeRelation() to prevent problems on multiprocessor machines
4 lines of code changed in:
Set req and res fields to volatile to prevent invalid reads on multiprocessor machines
4 lines of code changed in:
Synchronize thread -> scope map
7 lines of code changed in:
Fix registerUser(): user addNode() instead of setNode() so user nodes are stored as child nodes, not properties.
4 lines of code changed in:
Remove setDbMapping() which is never used and might be hazardous if it was.
2 lines of code changed in:
make class not final
3 lines of code changed in:
sznchronizing all methods that manipulate/access the buffer field
to avoid bogus rendering on multiprocessor machines.
14 lines of code changed in:
Add proxy method for Application.getSkin(String protoname, String skinname, Object[] skinpath)
14 lines of code changed in:
Go back to old log file rotation code layout a bit, but still only use one thread to gzip all rotated files:
- GZipper class is with FileLogger again and takes either a list of files or a single file
- Log file rotation is done synchronously in the Logging.Runner thread, only gzipping is done in
a separate thread
72 lines of code changed in:
Rewrote log file rotation to use just one thread for zipping all log files.
105 lines of code changed in:
Cleaned up constructor a bit, use direct assignment instead of setter for prototype.
3 lines of code changed in:
Do not try to set DbMapping in Node.setPrototype() - it has disastrous effects for prototyped groupby nodes.
8 lines of code changed in:
Set parent in MultiFileRepository child repositories, otherwise order is lost in Application.addRepository()
8 lines of code changed in:
- Make sure collections on transient nodes are set to transient when making persitable
to avoid collection objects being loaded from database.
- Allow getKey() to be called on transient nodes iff primary key is set
- Do set DbMapping in setPrototype() method
- Unified Node constructors and initializers a bit
22 lines of code changed in:
Fix bug 431
http://www.helma.org/bugs/show_bug.cgi?id=431
5 lines of code changed in:
MultiFileRepository contributed by Barbara Ondrisek:
A subclass of FileRepository that treats all subdirectories as top-level file repositories
(instead of than treating them as prototype directories)
121 lines of code changed in:
ignore-dirs patch contributed by Barbara Ondrisek:
appname.ignore = dir1,dir2 prevents Prototypes to be created for the given directories.
50 lines of code changed in:
ResourceComparator is never used with ResourceTrackers
2 lines of code changed in:
Simplified getInstance(String) a little bit.
6 lines of code changed in:
Set thread priority for GZipper threads to MIN_PRIORITY.
3 lines of code changed in:
- Remove old debug thread dump in getInstance(String)
- Remove double checking to avoid entering synchronized code in getInstance(String)
- Rename newLog(String) to getFileLogger(String) and clean it up a little bit
10 lines of code changed in:
Make Runner.run() synchronized again, needed by wait()
3 lines of code changed in:
Remove comment about bogus thread safety, not true anymore after last commit.
2 lines of code changed in:
- No need to make runner volatile since it is only access in synchronized code
- Do not null out Logging.runner at the end of Runner.run()
- Remove unused Runner.wakeup() method and make runner.run() not synchronized
4 lines of code changed in:
- Make sure we use an absolute path for logdir
- Make all methods that work on the logfile/writer synchronized
- Increase Buffer size in GZipper thread to 8192 bytes
13 lines of code changed in:
Make runner variable volatile.
3 lines of code changed in:
Pages: « Previous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 Next »
Generated by StatCVS 0.2.2